Got Error 10104?

Go down

Got Error 10104?

Post by LiffPill_ on Thu Jun 18, 2009 3:12 pm

Well,
I was getting this error pretty often, so I started to explore internet for possible answers.

Found few, first was to delete hakshield folder (don't work, the game just won't launch), second one was more real, it was said that this happen because of ATI graphic cards, well I thought that this could be it, at home I have geforce and it works, and at work I have ATI and it doesn't, changed graphic card to geforce and problem still occured.

Finally I found topic in which some explained that this may be due to some hardware, like MOUSE with more than usual number of keys. In my case I just deleted software that I installed (was with mouse) and it worked. No more error.
(note to that: even after uninstalling software given by the producer, mouse still works- keys as well)

Hope that I could help someone with this information.

Regards,
Liff
avatar
LiffPill_

Number of posts : 2
Age : 31
Registration date : 2009-06-18

View user profile

Back to top Go down

Re: Got Error 10104?

Post by Mondie on Thu Jun 18, 2009 3:16 pm

could you state what map were you in? Some people have been getting this kind of error as well, we thought it might be because of a map, but we're not so sure.

Thanks. Smile

-Mondie

_________________
[b]I'm known as Chutsie in-game. Smile [/b]
Hello! I'm your friendly Customer Service Representative! XD
avatar
Mondie
Admin

Number of posts : 342
Age : 28
In Game Name : Chutsie/[GM]Mondie
Registration date : 2009-03-14

View user profile http://aegisn.forumotion.com

Back to top Go down

Re: Got Error 10104?

Post by LiffPill_ on Thu Jun 18, 2009 3:21 pm

Well it occurred on all maps, didn't found any pattern for that, but it is a hakshield error, and it does happen in other games as well, that's why I thought that this error is not related to the game itself, but to this program.
Deleting drivers solve the problem, also found some information that it usually appears for user who has better mouse/keyboard with more buttons, hakshield don't like those. especially their software.

Regards,
Liff
avatar
LiffPill_

Number of posts : 2
Age : 31
Registration date : 2009-06-18

View user profile

Back to top Go down

Re: Got Error 10104?

Post by Mondie on Thu Jun 18, 2009 3:57 pm

oh lol. okay, thanks for your information! Smile

_________________
[b]I'm known as Chutsie in-game. Smile [/b]
Hello! I'm your friendly Customer Service Representative! XD
avatar
Mondie
Admin

Number of posts : 342
Age : 28
In Game Name : Chutsie/[GM]Mondie
Registration date : 2009-03-14

View user profile http://aegisn.forumotion.com

Back to top Go down

Re: Got Error 10104?

Post by sloantech on Thu Jun 18, 2009 5:00 pm

Perform the Hshield trick, that is a hackshield error found while in-game which is triggered by either a background program (yes other devices such as webcams being active can cause this or even Maya 2009). By doing the HShield trick nothing else on your system will need to change to be able to run RO2 properly.

1. In your System\HShield folder, rename the file EhScv.dll to _1EhScv.dll.
2.
Make a copy of the file Psapi.dll and paste it in the same folder (or
in another folder if you get the error “a file with the same name
already exists”)
3. Rename your COPIED Psapi.dll to EhScv.dll.
4. Move the new EhScv.dll into your HShield folder if it is not already there.
avatar
sloantech

Number of posts : 53
Age : 34
Location : Gotham City
In Game Name : Fooby
Registration date : 2009-05-13

View user profile http://www.yggro2.com

Back to top Go down

Re: Got Error 10104?

Post by Elixa on Thu Jun 18, 2009 11:47 pm

but sloan, these are the vista steps. to play RO2 on vista O-o?
avatar
Elixa
Admin

Number of posts : 314
Age : 28
In Game Name : Elixa / [ADM]Elixa
Registration date : 2009-03-14

View user profile http://www.aegisro2.co.nr

Back to top Go down

Re: Got Error 10104?

Post by sloantech on Fri Jun 19, 2009 12:52 am

No they are not "vista" steps in the least. This is to disable the hackshield program in a sense. Most people running Vista (not all though regardless of version, some need a normal EhScv.dll to run even with Vista) need to perform this step in order to get the game to run. However there are some people who need to do this due to background programs or a variety of other things which either intefere with hackshield OR are false positives detected by hackshield. This issue can occur to any uer, even on XP or 2k. Error 10505, 10604, 10606, 10105 and many others are due to this and most occur at either character selection screen OR within a set time frame (between 30 seconds to 5 min, but consistant). Nitewolf and I found the trigger for most error numbers, along with a few other issues such as having no text and the root cause of the C++ runtime issues, antivirus/firewall programs which always have issues and all their workarounds which I compiled into an FAQ that Divinia copied and posted onto their own site as theirs was horribly outdated. I removed it from Euph when I left but have it up on my forums currently if you want to use it.

These issues are why the client I made automatically performs this trick for all Vista users on install while containing a regular EhScv.dll "normal_EhScv" incase they are the exception to the rule (also installing both a .rar and .zip of RagII.exe in case antivirus deletes or quarantines it, thus allowing the user to configure their program/firewall and not having to download/search/reinstall)
avatar
sloantech

Number of posts : 53
Age : 34
Location : Gotham City
In Game Name : Fooby
Registration date : 2009-05-13

View user profile http://www.yggro2.com

Back to top Go down

Re: Got Error 10104?

Post by Dawn on Sat Jun 20, 2009 6:22 am

sloantech wrote:Perform the Hshield trick, that is a hackshield error found while in-game which is triggered by either a background program (yes other devices such as webcams being active can cause this or even Maya 2009). By doing the HShield trick nothing else on your system will need to change to be able to run RO2 properly.

1. In your System\HShield folder, rename the file EhScv.dll to _1EhScv.dll.
2.
Make a copy of the file Psapi.dll and paste it in the same folder (or
in another folder if you get the error “a file with the same name
already exists”)
3. Rename your COPIED Psapi.dll to EhScv.dll.
4. Move the new EhScv.dll into your HShield folder if it is not already there.
Will this let me use my game controller to play the game again? >: I really hope it does.
avatar
Dawn
Admin

Number of posts : 20
Age : 28
Location : ???
In Game Name : NekoWitch Dawn
Registration date : 2009-05-30

View user profile

Back to top Go down

Re: Got Error 10104?

Post by Mondie on Sat Jun 20, 2009 6:27 am

I think it will. ^_- I tried running another hackshield game side by side with our client, and it works, which would probably mean that the HShield here is disabled.

_________________
[b]I'm known as Chutsie in-game. Smile [/b]
Hello! I'm your friendly Customer Service Representative! XD
avatar
Mondie
Admin

Number of posts : 342
Age : 28
In Game Name : Chutsie/[GM]Mondie
Registration date : 2009-03-14

View user profile http://aegisn.forumotion.com

Back to top Go down

Re: Got Error 10104?

Post by sloantech on Sat Jun 20, 2009 6:28 am

It might, game controllers+RO2 are VERY ..... finicky would be the forum appropriate word. It is very dependent on the driver/hardware itself and how it decides to act with the computer/RO2. I'd need to see exactly what hardware/driver you are talking about and what error you receive before I'd troubleshoot it any further.
avatar
sloantech

Number of posts : 53
Age : 34
Location : Gotham City
In Game Name : Fooby
Registration date : 2009-05-13

View user profile http://www.yggro2.com

Back to top Go down

Re: Got Error 10104?

Post by Dawn on Sat Jun 20, 2009 6:29 am

Yay, I can finally play RO2 from downstairs using my Wiimote. Hehe xD so cool. cant wait to try it out.

lol I used to play kRO2 with my Wiimote controller (bluetooth) but then came HackShield and ruined my RO2 life ._.; buu.


Last edited by Dawn on Sat Jun 20, 2009 6:31 am; edited 1 time in total
avatar
Dawn
Admin

Number of posts : 20
Age : 28
Location : ???
In Game Name : NekoWitch Dawn
Registration date : 2009-05-30

View user profile

Back to top Go down

Re: Got Error 10104?

Post by sloantech on Sat Jun 20, 2009 6:31 am

I didn't make any promises lol... but I'll help troubleshoot you through any errors. Just as long as I don't have to act all formal, it was the reason I turned down the MVP position for WoW's tech support forum and the same reason Thunderwulf accepted it haha.
avatar
sloantech

Number of posts : 53
Age : 34
Location : Gotham City
In Game Name : Fooby
Registration date : 2009-05-13

View user profile http://www.yggro2.com

Back to top Go down

Re: Got Error 10104?

Post by Dawn on Sat Jun 20, 2009 6:33 am

it's fine, if it doesn't work I have a source code to actually 'Kill' HS. but I don't know how to use it x3 in that sense. but yeah even if it doesn't work I won't to much about using a gaming controller. =.=.. since I am well used to how my tiny hands fit over this keyboard now. it's not as much a problem as it was back then. ;;
avatar
Dawn
Admin

Number of posts : 20
Age : 28
Location : ???
In Game Name : NekoWitch Dawn
Registration date : 2009-05-30

View user profile

Back to top Go down

Re: Got Error 10104?

Post by Sponsored content


Sponsored content


Back to top Go down

Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum